読者です 読者をやめる 読者になる 読者になる

toyo's code

アニソンシンガー目指す傍らプログラマしてます。

RDS MySQLのバージョンを5.7にアップグレードする

BEC Inc.にジョインしてから技術ブログを書いてなかった😂

ローカル環境でのテスト環境を整備するにあたって、MySQLのバージョンを揃えたかったので、RDSに合わせて古いバージョンをローカルで使うのではなく、RDS MySQLのバージョンを5.6.27から5.7.16にアップグレードするようにした。
その時やったことのメモ。

といってもパラメーターグループがなかっただけだけど😉

RDSでcharset周りをUTF8にするためのパラメーターグループが割り当てられていた。
その状態でMySQLのバージョンを5.7系に上げようとすると以下のエラーが出た。

Current Parameter Group (charset) is non-default. You need to explicitly specify a new Parameter Group in this case (default or custom) (Service: AmazonRDS; Status Code: 400; Error Code: InvalidParameterCombination; Request ID: なんたらなんたら)

デフォルトやったら問題なくアップグレードされるんかな。
これはデフォルトではないパラメーターグループを割り当てていて、MySQL5.7のパラメータグループファミリーが存在しないので出るっぽい。

パラメーターグループを作った後は、既存のパラメーターグループと「パラメーターの比較」などをして、設定した項目に差分が出ないことを確認するとよい。 (もとより、5.6と5.7のものを比較しているので差分がたくさん出る?ので、設定した項目が出ているか確認すればよさそう。RDSの設定を管理するツールとか無いんだっけ)

あとはインスタンスの変更からMySQLのバージョンをあげればOK。

今のプロジェクトはエンジニアが一人で作ってきていて結構改善点が多い。
粛々と破壊的リファクタ奴をやってるから、割とネタたまってきたのでちょいちょい投下していきたい⚒